Status
Get in touch
Back
Maintenance
Systems maintenance
Completed 18 Aug at 07:30pm UTC.
Affected services
app.software.com
Completed
Maintenance completed
Posted 18 Aug at 07:30pm UTC.
Started
Maintenance window.
Posted 18 Aug at 07:00pm UTC.