Data Processing Delays - Plugins Affected
Incident Report for Software.com
Postmortem

We’ve been working hard to improve our performance when it comes to processing users' data payloads. We know this is super critical to our users, and the value they get from our tools.

Performance has proved an ongoing challenge, but a recent switch to a message queue architecture has led to some great improvements in processing capacity. These recent service incidents have been related to this new release as we work out the inevitable bugs that come along with big changes.

Onwards and upwards!

Posted 4 months ago. Jun 12, 2019 - 00:41 PDT

Resolved
A problem with our processing queues has been resolved and plugin data updates are back to full capacity.
Posted 4 months ago. Jun 11, 2019 - 23:30 PDT
Investigating
Our data collection endpoint is experiencing processing delays causing timeouts.
Posted 4 months ago. Jun 11, 2019 - 10:29 PDT
This incident affected: API and Web App.